CodeTogether Compatibility

IDEs

You can host or join a session from any of our supported IDEs by installing the CodeTogether plugin/extension. 

Hosting a Session

To host a CodeTogether session, your IDE must meet the following minimum requirement:

  • Eclipse (4.6/Neon or higher)
  • IntelliJ family* (2019.1 or higher)
  • VS Code (1.44 or higher)

Joining a Session

To join a CodeTogether session from your IDE, your IDE must meet the following minimum requirement:

  • Eclipse (4.8/Photon or higher)
  • IntelliJ family* (2019.2 or higher)
  • VS Code (1.44 or higher)

*All IntelliJ-based IDEs, including IntelliJ IDEA, WebStorm, PyCharm, Rider, etc.

Web Browsers

To join a running CodeTogether session from a browser, a compatible browser is required.

Supported

CodeTogether is compatible and has been tested with recent versions of the following browsers:

  • Chrome
  • Firefox
  • Safari
  • Opera
    Note: The Content Assist shortcut (Ctrl + Space) conflicts with the Search key binding. Unbind Search to use Content Assist in the editor.
  • Edge (version 44 and higher, including recent Chromium based builds)

Unsupported

  • Internet Explorer