CodeTogether for JetBrains IDEs Installation Guide

Installing the CodeTogether Plugin​

CodeTogether requires a JetBrains IntelliJ-based IDE 2019.1 or higher You have two options when installing the CodeTogether plugin:

Installing the ZIP File in IntelliJ

If you choose to download the ZIP file, complete these steps to add the CodeTogether plugin to your IntelliJ-based IDE.

  1. In the IDE, go to Settings/Preferences (Ctrl+Alt+S) and select Plugins.
  2. On the Plugins page, click the Settings button, and then click Install Plugin from Disk.

  3. Select the downloaded ZIP file and click OK.
  4. Start collaborating! See the CodeTogether Getting Started Guide for details.

Starting and Stopping a Session

In the CodeTogether view (View > Tool Windows > CodeTogether), click Start Sharing.

You can also start a session by: selecting Tools > CodeTogether: Start Sharing or searching for the CodeTogether: Start Sharing action.

When the session starts, the URL to invite others to the session is automatically copied to your clipboard.

If you need to get the URL later, use any of the following options:

  • In the CodeTogether view, click Invite.
  • Select Tools > CodeTogether: Invite.
  • Search for the CodeTogether: Invite action.

To stop the session, use any of the following options:

  • In the CodeTogether view, click Stop Sharing.
  • Select Tools > CodeTogether: Stop Sharing.
  • Search for the CodeTogether: Stop Sharing action.

For more information, see the Getting Started Guide.